В декабре 2018 года PHP 5.6 и 7.0 перестанут получать обновления безопасности. В WordPress сообщили, что эти версии используются на 57,1% WP-сайтов. Это значит, что в скором времени эти ресурсы станут менее защищенными.

Использование устаревших версий PHP грозит сайтам потерей трафика и проблемами с ранжированием. Кроме того, повышается риск пострадать в результате хакерской атаки, возможны проблемы с работой отдельных плагинов и самой WordPress. Владельцам сайтов рекомендуется как можно быстрее обновить PHP до последней версии.

Обновления безопасности для PHP 5.6 перестанут выходить 31 декабря 2018 года. А поддержка PHP 7.0 прекратится 3 декабря.

Как определить, какая версия PHP сейчас используется

Для этого нужно зайти в панель управления хостинга и найти ссылку на раздел, связанный с PHP. Можно использовать специальные онлайн-инструменты и плагины.

Также можно связаться со службой поддержки хостинг-провайдера и попросить определить, какая версия PHP используется сайтом.

Как обновить PHP до последней версии

Сначала необходимо создать резервную копию своего WordPress-сайта. Для этого можно воспользоваться плагином UpDraftPlus. Затем потребуется проверить совместимость плагинов – убедиться, что все плагины были обновлены до последней версии:

  • Если плагин долго не обновлялся, нужно зайти на его страницу и проверить, совместим ли он с последней версией PHP (7.2).
  • Если окажется, что плагин несовместим, его нужно заменить на другой с той же функциональностью. Использование несовместимых с PHP плагинов может повлечь за собой угрозы безопасности.

После проверки можно будет обновить PHP. Потребуется зайти в панель управления хостингом и найти раздел, посвященный PHP, а затем обновить PHP-версию сайта до последней. При возникновении трудностей лучше связаться со службой поддержки хостинг-провайдера.

Источник: Search Engine Journal
Источник: seonews.ru